Archive for junho, 2009

As cantadas do Pedreiro Geek

Direto da Lan House do Purgatório, excelente e hilário post: http://migre.me/2i5C
É só conferir…
Até.

Anúncios

terça-feira, 16 junho, 2009 at 11:33 am Deixe um comentário

Google entra no mercado de banco de dados

Eu acho que eles querem mesmo dominar o mundo: http://migre.me/26gz.

O nome da tecnologia é Fusion Tables e tem o objetivo de revolucionar o gerenciamento de dados através de um sistema chamado “espaço de dados”.

“O Fusion Tables também oferece uma tecnologia de espaço de dados, conceito que existe desde os anos 90 e o Google, percebendo seu potencial, o desenvolve desde a compra da Transformic, em 2005, que é uma pioneira da tecnologia.”

Como sempre o produto é uma versão prévia (beta)…

Comunicado ofical do Google: http://googleresearch.blogspot.com/2009/06/google-fusion-tables.html

É clicar, esperar e conferir

sexta-feira, 12 junho, 2009 at 7:21 pm Deixe um comentário

Recursividade – Algoritmo de Euclides recursivo

A recursividade é um recurso extremamente útil e poderoso tanto na matemática quanto na ciência da computação. Na informática, diz respeito a uma função que chama a si própria. Na matemática a um processo que é definido em termos de si mesmo. A melhor definição de recursividade, com os melhores exemplos, aquela que me fez realmente aprender a recursividade originou-se deste livro: Estruturas de dados usando C de Tenenbaum et al.  Maiores informações sobre recursividade podem ser obtidas aqui, aqui e aqui.

O algoritmo de Euclides demonstrado anteriormente tem uma versão recursiva bem elegante. Segue sua versão para o Visualg:

 algoritmo "Euclides recursivo"
// Função : Euclides Recursivo
// Autor :  Ed
// Data : 31/05/2009
// Seção de Declarações
var
a,b: inteiro

funcao mdc_rec (x:inteiro; y:inteiro):inteiro
var
dividendo,divisor: inteiro
inicio
dividendo<-x
divisor<-y
se divisor=0 entao
 retorne dividendo
senao
 retorne mdc_rec(divisor, dividendo%divisor)
fimse

fimfuncao

inicio
//entrada de dados
escreval()
escreval("Algoritmo de Euclides para encontrar o MDC entre 2 números")
escreval()
escreva("Digite o primeiro numero:")
leia (a)
escreva("Digite o segundo numero:")
leia (b)
escreval()
escreva ("O MDC de ", a," e ", b, " é ", mdc_rec(a,b))
escreval()
fimalgoritmo

quinta-feira, 11 junho, 2009 at 7:34 pm 10 comentários

Evolução dos games

Muito bom este post sobre a evolução dos videogames de 1990 a 2009. Direto daqui, via twitter.

Recomendo para quem gosta de games. Lágrimas não valem, por favor!!!

segunda-feira, 8 junho, 2009 at 11:54 am Deixe um comentário


Follow Computador de papel: o conteúdo da forma on WordPress.com

Feeds

direto do Twitter

O Computador de Papel

O computador de papel nada mais é do que a tentativa de "humanizar" o computador, trazê-lo para a fantasia lúdica da realidade, fazê-lo compreendido pelos milhares que o usam, mas não o entendem. Nasceu de minhas viagens intelectuais defronte da tela de fósforo um dia em que ele retrucou-me: decifra-me ou te devoro. Para não ser devorado, ousei decifrá-lo. É também onde posto minhas aulas, meus trabalhos, minhas impressões de um pouco de nada sobre coisa nenhuma. É o local onde falo das minhas paixões, entre elas, a música, o cinema, a TI e a ciência. É um espaço de discussão sobre a realidade do computador, sua influência, seus avanços, o exercício do óbvio que é mostrar a sua importância no e para o mundo. Tem o estilo de seu criador, acelerado, com um tom sempre professoral, tresloucado, por vezes verborrágico, insano, nevrálgico, sem arroubos literários, atônito e contemplativo diante da realidade, apaixonado, livre, feito para mostrar que a TI é antes de tudo, feita por gente!

Estatísticas do blog

  • 126,219 cliques e contando...

Agenda de posts

junho 2009
S T Q Q S S D
« maio   jul »
1234567
891011121314
15161718192021
22232425262728
2930